summaryrefslogtreecommitdiffstats
path: root/lass/2configs/backup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/backup.nix')
-rw-r--r--lass/2configs/backup.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/lass/2configs/backup.nix b/lass/2configs/backup.nix
new file mode 100644
index 00000000..27adf6d2
--- /dev/null
+++ b/lass/2configs/backup.nix
@@ -0,0 +1,20 @@
+{ config, lib, ... }:
+with import <stockholm/lib>;
+
+{
+ fileSystems = {
+ "/backups" = {
+ device = "/dev/pool/backup";
+ fsType = "ext4";
+ };
+ };
+ users.users.backup = {
+ useDefaultShell = true;
+ home = "/backups";
+ createHome = true;
+ openssh.authorizedKeys.keys = with config.krebs.hosts; [
+ mors.ssh.pubkey
+ prism.ssh.pubkey
+ ];
+ };
+}