summaryrefslogtreecommitdiffstats
path: root/lass/2configs/IM.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/IM.nix')
-rw-r--r--lass/2configs/IM.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/lass/2configs/IM.nix b/lass/2configs/IM.nix
deleted file mode 100644
index 8db2a05d..00000000
--- a/lass/2configs/IM.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-with (import <stockholm/lib>);
-{ config, lib, pkgs, ... }: let
- weechat = pkgs.weechat.override {
- configure = { availablePlugins, ... }: {
- scripts = with pkgs.weechatScripts; [
- weechat-matrix
- ];
- };
- };
-
- tmux = "/run/current-system/sw/bin/tmux";
-
-in {
- imports = [
- ./bitlbee.nix
- ];
- environment.systemPackages = [ weechat ];
- systemd.services.chat = {
- description = "chat environment setup";
- environment.WEECHAT_HOME = "\$HOME/.weechat";
- after = [ "network.target" ];
- wantedBy = [ "multi-user.target" ];
-
- restartIfChanged = false;
-
- path = [
- pkgs.rxvt-unicode-unwrapped.terminfo
- ];
-
- serviceConfig = {
- User = "lass";
- RemainAfterExit = true;
- Type = "oneshot";
- ExecStart = "${tmux} -2 new-session -d -s IM ${weechat}/bin/weechat";
- ExecStop = "${tmux} kill-session -t IM"; # TODO run save in weechat
- };
- };
-}