summaryrefslogtreecommitdiffstats
path: root/lass/1systems/xerxes/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/xerxes/physical.nix')
-rw-r--r--lass/1systems/xerxes/physical.nix86
1 files changed, 86 insertions, 0 deletions
diff --git a/lass/1systems/xerxes/physical.nix b/lass/1systems/xerxes/physical.nix
new file mode 100644
index 00000000..f88578e1
--- /dev/null
+++ b/lass/1systems/xerxes/physical.nix
@@ -0,0 +1,86 @@
+{ pkgs, lib, ... }:
+{
+ imports = [
+ ./config.nix
+ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.zfs.enableUnstable = true;
+ boot.loader.grub = {
+ enable = true;
+ device = "/dev/sda";
+ efiSupport = true;
+ };
+ boot.loader.efi.canTouchEfiVariables = true;
+
+ # TODO fix touchscreen
+ boot.blacklistedKernelModules = [
+ "goodix"
+ ];
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usbhid" "sd_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.initrd.luks.devices.crypted.device = "/dev/sda3";
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+ boot.kernelParams = [
+ "fbcon=rotate:1"
+ "boot.shell_on_fail"
+ ];
+
+ services.xserver.displayManager.sessionCommands = ''
+ (sleep 2 && ${pkgs.xorg.xrandr}/bin/xrandr --output eDP-1 --rotate right)
+ (sleep 2 && ${pkgs.xorg.xinput}/bin/xinput set-prop 'Goodix Capacitive TouchScreen' 'Coordinate Transformation Matrix' 0 1 0 -1 0 1 0 0 1)
+ '';
+
+ fileSystems."/" = {
+ device = "rpool/root";
+ fsType = "zfs";
+ };
+
+ fileSystems."/home" = {
+ device = "rpool/home";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" = {
+ device = "/dev/disk/by-uuid/E749-784C";
+ fsType = "vfat";
+ };
+
+ swapDevices = [ ];
+
+ boot.extraModprobeConfig = ''
+ options zfs zfs_arc_max=1073741824
+ '';
+
+ nix.maxJobs = lib.mkDefault 4;
+
+ networking.hostId = "9b0a74ac";
+ networking.networkmanager.enable = true;
+
+ hardware.opengl.enable = true;
+
+ services.tlp.enable = true;
+ services.tlp.extraConfig = ''
+ CPU_SCALING_GOVERNOR_ON_AC=ondemand
+ CPU_SCALING_GOVERNOR_ON_BAT=powersave
+ CPU_MIN_PERF_ON_AC=0
+ CPU_MAX_PERF_ON_AC=100
+ CPU_MIN_PERF_ON_BAT=0
+ CPU_MAX_PERF_ON_BAT=30
+ '';
+
+ services.logind.extraConfig = ''
+ HandlePowerKey=suspend
+ IdleAction=suspend
+ IdleActionSec=300
+ '';
+
+ services.xserver.extraConfig = ''
+ Section "Device"
+ Identifier "Intel Graphics"
+ Driver "Intel"
+ Option "TearFree" "true"
+ EndSection
+ '';
+}