summaryrefslogtreecommitdiffstats
path: root/lass/1systems/xerxes/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/xerxes/config.nix')
-rw-r--r--lass/1systems/xerxes/config.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/lass/1systems/xerxes/config.nix b/lass/1systems/xerxes/config.nix
new file mode 100644
index 00000000..b393f203
--- /dev/null
+++ b/lass/1systems/xerxes/config.nix
@@ -0,0 +1,35 @@
+{ config, lib, pkgs, ... }:
+
+{
+ imports = [
+ <stockholm/lass>
+
+ <stockholm/lass/2configs/retiolum.nix>
+ <stockholm/lass/2configs/exim-retiolum.nix>
+ <stockholm/lass/2configs/baseX.nix>
+ <stockholm/lass/2configs/browsers.nix>
+ <stockholm/lass/2configs/programs.nix>
+ <stockholm/lass/2configs/network-manager.nix>
+ <stockholm/lass/2configs/syncthing.nix>
+ <stockholm/lass/2configs/games.nix>
+ <stockholm/lass/2configs/steam.nix>
+ <stockholm/lass/2configs/wine.nix>
+ <stockholm/lass/2configs/fetchWallpaper.nix>
+ <stockholm/lass/2configs/nfs-dl.nix>
+ <stockholm/lass/2configs/pass.nix>
+ <stockholm/lass/2configs/mail.nix>
+ ];
+
+ krebs.build.host = config.krebs.hosts.xerxes;
+
+ services.xserver = {
+ displayManager.lightdm.autoLogin.enable = true;
+ displayManager.lightdm.autoLogin.user = "lass";
+ };
+
+ boot.blacklistedKernelModules = [
+ "xpad"
+ ];
+
+ lass.screenlock.enable = lib.mkForce false;
+}