summaryrefslogtreecommitdiffstats
path: root/lass/1systems/red/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/red/config.nix')
-rw-r--r--lass/1systems/red/config.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/lass/1systems/red/config.nix b/lass/1systems/red/config.nix
new file mode 100644
index 00000000..8c60aed6
--- /dev/null
+++ b/lass/1systems/red/config.nix
@@ -0,0 +1,30 @@
+with import <stockholm/lib>;
+{ config, lib, pkgs, ... }:
+let
+ inherit (import <stockholm/lass/2configs/websites/util.nix> {inherit lib pkgs;})
+ servephpBB
+ ;
+in
+{
+ imports = [
+ <stockholm/lass>
+ <stockholm/lass/2configs>
+ <stockholm/lass/2configs/retiolum.nix>
+ <stockholm/lass/2configs/websites>
+ <stockholm/lass/2configs/websites/sqlBackup.nix>
+ (servephpBB [ "rote-allez-fraktion.de" ])
+ ];
+
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 80"; target = "ACCEPT"; }
+ ];
+
+ krebs.build.host = config.krebs.hosts.red;
+ boot.isContainer = true;
+ networking.useDHCP = false;
+
+ services.nginx.enable = true;
+ environment.systemPackages = [
+ pkgs.mk_sql_pair
+ ];
+}