summaryrefslogtreecommitdiffstats
path: root/lass/1systems/lasspi/physical.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/lasspi/physical.nix')
-rw-r--r--lass/1systems/lasspi/physical.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/lass/1systems/lasspi/physical.nix b/lass/1systems/lasspi/physical.nix
deleted file mode 100644
index 868bafad..00000000
--- a/lass/1systems/lasspi/physical.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{ config, lib, pkgs, ... }:
-{
- # This configuration worked on 09-03-2021 nixos-unstable @ commit 102eb68ceec
- # The image used https://hydra.nixos.org/build/134720986
- imports = [
- ./config.nix
- ];
-
- boot = {
- # kernelPackages = pkgs.linuxPackages_rpi4;
- tmpOnTmpfs = true;
- initrd.availableKernelModules = [ "usbhid" "usb_storage" ];
- # ttyAMA0 is the serial console broken out to the GPIO
- kernelParams = [
- "8250.nr_uarts=1"
- "console=ttyAMA0,115200"
- "console=tty1"
- # Some gui programs need this
- "cma=128M"
- ];
- };
-
- boot.loader.raspberryPi = {
- enable = true;
- version = 4;
- };
- boot.loader.grub.enable = false;
-
- # Required for the Wireless firmware
- hardware.enableRedistributableFirmware = true;
-
- # Assuming this is installed on top of the disk image.
- fileSystems = {
- "/" = {
- device = "/dev/disk/by-label/NIXOS_SD";
- fsType = "ext4";
- options = [ "noatime" ];
- };
- };
-
- powerManagement.cpuFreqGovernor = "ondemand";
-}