summaryrefslogtreecommitdiffstats
path: root/lass/1systems/helios/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/helios/config.nix')
-rw-r--r--lass/1systems/helios/config.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/lass/1systems/helios/config.nix b/lass/1systems/helios/config.nix
index 23307e9a..b14ef2a3 100644
--- a/lass/1systems/helios/config.nix
+++ b/lass/1systems/helios/config.nix
@@ -14,6 +14,8 @@ with import <stockholm/lib>;
#<stockholm/lass/2configs/git.nix>
<stockholm/lass/2configs/dcso-vpn.nix>
<stockholm/lass/2configs/virtualbox.nix>
+ <stockholm/lass/2configs/dcso-dev.nix>
+ <stockholm/lass/2configs/steam.nix>
{ # automatic hardware detection
boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
boot.kernelModules = [ "kvm-intel" ];
@@ -61,6 +63,13 @@ with import <stockholm/lib>;
maxTime = 9001;
};
}
+ {
+ #urban terror port
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-p tcp --dport 27960"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 27960"; target = "ACCEPT"; }
+ ];
+ }
];
krebs.build.host = config.krebs.hosts.helios;
@@ -92,7 +101,6 @@ with import <stockholm/lib>;
environment.systemPackages = with pkgs; [
ag
vim
- rxvt_unicode
git
rsync
hashPassword