summaryrefslogtreecommitdiffstats
path: root/lass/1systems/cloudkrebs/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/cloudkrebs/config.nix')
-rw-r--r--lass/1systems/cloudkrebs/config.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/lass/1systems/cloudkrebs/config.nix b/lass/1systems/cloudkrebs/config.nix
new file mode 100644
index 00000000..aa9a1f1a
--- /dev/null
+++ b/lass/1systems/cloudkrebs/config.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import <stockholm/lass/4lib> { inherit pkgs lib; }) getDefaultGateway;
+ ip = config.krebs.build.host.nets.internet.ip4.addr;
+in {
+ imports = [
+ <stockholm/lass>
+ <stockholm/lass/2configs/retiolum.nix>
+ <stockholm/lass/2configs/os-templates/CAC-CentOS-7-64bit.nix>
+ <stockholm/lass/2configs/exim-retiolum.nix>
+ <stockholm/lass/2configs/git.nix>
+ <stockholm/lass/2configs/realwallpaper.nix>
+ <stockholm/lass/2configs/privoxy-retiolum.nix>
+ {
+ networking.interfaces.enp2s1.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = getDefaultGateway ip;
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.cloudkrebs;
+}