summaryrefslogtreecommitdiffstats
path: root/lass/1systems/aergia/disk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/aergia/disk.nix')
-rw-r--r--lass/1systems/aergia/disk.nix63
1 files changed, 0 insertions, 63 deletions
diff --git a/lass/1systems/aergia/disk.nix b/lass/1systems/aergia/disk.nix
deleted file mode 100644
index 233b320e..00000000
--- a/lass/1systems/aergia/disk.nix
+++ /dev/null
@@ -1,63 +0,0 @@
-{ lib, ... }:
-{
- disk = {
- main = {
- type = "disk";
- device = "/dev/nvme0n1";
- content = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- name = "boot";
- start = "0";
- end = "1M";
- part-type = "primary";
- flags = ["bios_grub"];
- }
- {
- name = "ESP";
- start = "1MiB";
- end = "1GiB";
- fs-type = "fat32";
- bootable = true;
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- };
- }
- {
- name = "root";
- start = "1GiB";
- end = "100%";
- content = {
- type = "luks";
- name = "aergia1";
- content = {
- type = "btrfs";
- extraArgs = "-f"; # Override existing partition
- subvolumes = {
- # Subvolume name is different from mountpoint
- "/rootfs" = {
- mountpoint = "/";
- };
- # Mountpoints inferred from subvolume name
- "/home" = {
- mountOptions = [];
- mountpoint = "/home";
- };
- "/nix" = {
- mountOptions = [];
- mountpoint = "/nix";
- };
- };
- };
- };
- }
- ];
- };
- };
- };
-}
-