summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/urlwatch/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/urlwatch/default.nix')
-rw-r--r--krebs/5pkgs/simple/urlwatch/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/urlwatch/default.nix b/krebs/5pkgs/simple/urlwatch/default.nix
new file mode 100644
index 00000000..7ffbd887
--- /dev/null
+++ b/krebs/5pkgs/simple/urlwatch/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl, python3Packages }:
+
+python3Packages.buildPythonPackage rec {
+ name = "urlwatch-2.5";
+
+ src = fetchurl {
+ url = "https://thp.io/2008/urlwatch/${name}.tar.gz";
+ sha256 = "0qirpymdmpsx0klmhbx3icmiwpm6fx4wjma646gl9m90pifs8430";
+ };
+
+ propagatedBuildInputs = with python3Packages; [
+ keyring
+ minidb
+ pyyaml
+ requests2
+ ];
+
+ meta = {
+ description = "A tool for monitoring webpages for updates";
+ homepage = https://thp.io/2008/urlwatch/;
+ license = stdenv.lib.licenses.bsd3;
+ maintainers = [ stdenv.lib.maintainers.tv ];
+ };
+}