summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/tarantool/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/tarantool/default.nix')
-rw-r--r--krebs/5pkgs/simple/tarantool/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/tarantool/default.nix b/krebs/5pkgs/simple/tarantool/default.nix
new file mode 100644
index 00000000..9e22fd4f
--- /dev/null
+++ b/krebs/5pkgs/simple/tarantool/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchgit, cmake, ncurses, openssl, readline, ... }:
+
+stdenv.mkDerivation rec {
+ name = "tarantool-1.7.1-164-g0fd0239";
+ src = fetchgit {
+ url = https://github.com/tarantool/tarantool;
+ rev = builtins.elemAt (builtins.match ".*-g([0-9a-f]+)" name) 0;
+ sha256 = "1jnaiizbl9j4a8vsihqx75iqa9bkh1kpwsyrgmim8ikiyzfw54dz";
+ fetchSubmodules = true;
+ };
+ buildInputs = [
+ cmake
+ ncurses
+ openssl
+ readline
+ ];
+ preConfigure = ''
+ echo ${(builtins.parseDrvName name).version} > VERSION
+ sed -i 's/NAMES termcap/NAMES ncurses/' cmake/FindTermcap.cmake
+ '';
+}