summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/retiolum-bootstrap/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/retiolum-bootstrap/default.nix')
-rw-r--r--krebs/5pkgs/simple/retiolum-bootstrap/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/retiolum-bootstrap/default.nix b/krebs/5pkgs/simple/retiolum-bootstrap/default.nix
new file mode 100644
index 00000000..331b1cb7
--- /dev/null
+++ b/krebs/5pkgs/simple/retiolum-bootstrap/default.nix
@@ -0,0 +1,29 @@
+{ stdenv,lib,fetchurl, ... }:
+with lib;
+stdenv.mkDerivation rec {
+ name = "retiolum-bootstrap";
+ version = "4.2.3";
+
+
+ src = fetchurl {
+ url = https://raw.githubusercontent.com/krebscode/painload/master/retiolum/scripts/tinc_setup/new_install.sh;
+ sha256 = "03kmil8q2xm3rdm2jxyah7vww84pw6w01d0c3siid9zpn2j7la9s";
+ };
+
+ phases = [
+ "installPhase"
+ ];
+
+ installPhase = ''
+ mkdir -p "$out"
+ cp -a ${src} $out/retiolum.sh
+ '';
+
+ meta = {
+ description = "Retiolum boostrap scripts";
+ url = https://github.com/krebscode/painload;
+ license = licenses.wtfpl;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ makefu ];
+ };
+}