summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/repo-sync/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/repo-sync/default.nix')
-rw-r--r--krebs/5pkgs/simple/repo-sync/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/repo-sync/default.nix b/krebs/5pkgs/simple/repo-sync/default.nix
new file mode 100644
index 00000000..7cba87b0
--- /dev/null
+++ b/krebs/5pkgs/simple/repo-sync/default.nix
@@ -0,0 +1,21 @@
+{ lib, pkgs, python3Packages, fetchurl, ... }:
+
+with python3Packages; buildPythonPackage rec {
+ name = "repo-sync-${version}";
+ version = "0.2.6";
+ disabled = isPy26 || isPy27;
+ propagatedBuildInputs = [
+ docopt
+ GitPython
+ pkgs.git
+ ];
+ src = fetchurl {
+ url = "https://pypi.python.org/packages/source/r/repo-sync/repo-sync-${version}.tar.gz";
+ sha256 = "1hqa9qw9qg7mxgniqzys9szycs05llg4yik8a9wz94a437zzarsk";
+ };
+ meta = {
+ homepage = http://github.com/makefu/repo-sync;
+ description = "Sync remotes to other remotes.";
+ license = lib.licenses.mit;
+ };
+}