summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/quote.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/quote.nix')
-rw-r--r--krebs/5pkgs/simple/quote.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/quote.nix b/krebs/5pkgs/simple/quote.nix
new file mode 100644
index 00000000..7731e14b
--- /dev/null
+++ b/krebs/5pkgs/simple/quote.nix
@@ -0,0 +1,13 @@
+{ jq, writeDashBin }:
+
+# usage: quote [ARGS...]
+writeDashBin "quote" ''
+ set -efu
+ prefix=
+ for x; do
+ y=$(${jq}/bin/jq -nr --arg x "$x" '$x | @sh "\(.)"')
+ echo -n "$prefix$y"
+ prefix=' '
+ done
+ echo
+''