summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/realwallpaper.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/realwallpaper.nix')
-rw-r--r--krebs/5pkgs/realwallpaper.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/krebs/5pkgs/realwallpaper.nix b/krebs/5pkgs/realwallpaper.nix
new file mode 100644
index 00000000..4fea977e
--- /dev/null
+++ b/krebs/5pkgs/realwallpaper.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchgit, xplanet, imagemagick, curl, file }:
+
+stdenv.mkDerivation {
+ name = "realwallpaper";
+
+ src = fetchgit {
+ url = https://github.com/Lassulus/realwallpaper;
+ rev = "c2778c3c235fc32edc8115d533a0d0853ab101c5";
+ sha256 = "0yhbjz19zk8sj5dsvccm6skkqq2vardn1yi70qmd5li7qvp17mvs";
+ };
+
+ phases = [
+ "unpackPhase"
+ "installPhase"
+ ];
+
+ buildInputs = [
+ xplanet
+ imagemagick
+ curl
+ file
+ ];
+
+ installPhase = ''
+ mkdir -p $out
+ cp realwallpaper.sh $out/realwallpaper.sh
+ '';
+}