summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/much/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/much/default.nix')
-rw-r--r--krebs/5pkgs/much/default.nix66
1 files changed, 1 insertions, 65 deletions
diff --git a/krebs/5pkgs/much/default.nix b/krebs/5pkgs/much/default.nix
index f28e0b5b..ba5ab232 100644
--- a/krebs/5pkgs/much/default.nix
+++ b/krebs/5pkgs/much/default.nix
@@ -1,70 +1,6 @@
{ pkgs, ... }:
-let
- hspkgs = pkgs.haskellngPackages.override {
- overrides = self: super: {
- blessings = self.callPackage (
-{ mkDerivation, base, fetchgit, stdenv }:
-mkDerivation {
- pname = "blessings";
- version = "1.0.0";
- src = fetchgit {
- url = http://cgit.cd.retiolum/blessings;
- rev = "25a510dcb38ea9158e9969d56eb66cb1b860ab5f";
- sha256 = "b962153e80e51519b52220199d8350b54154833e4bc25a792ecc58898fef3fb2";
- };
- libraryHaskellDepends = [ base ];
- doHaddock = false;
- # WTFPL is the true license, which is unknown to cabal.
- license = stdenv.lib.licenses.wtfpl;
-}
-) {};
- email-header = self.callPackage (
-{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
-, case-insensitive, containers, exceptions, fetchgit, QuickCheck
-, stdenv, tasty, tasty-quickcheck, text, text-icu, time
-}:
-mkDerivation {
- pname = "email-header";
- version = "0.3.0";
- src = fetchgit {
- url = "https://github.com/4z3/email-header";
- sha256 = "f33fba567a39b1f2448869b269c26c40d8007599c23ab83bde5b4dfd9fd76ebc";
- rev = "7b179bd31192ead8afe7a0b6e34bcad4039deaa8";
- };
- buildDepends = [
- attoparsec base base64-bytestring bytestring case-insensitive
- containers exceptions text text-icu time
- ];
- testDepends = [
- base bytestring case-insensitive containers QuickCheck tasty
- tasty-quickcheck text time
- ];
- jailbreak = true;
- homepage = "http://github.com/knrafto/email-header";
- description = "Parsing and rendering of email and MIME headers";
- license = stdenv.lib.licenses.bsd3;
-}
-) {};
- scanner = self.callPackage (
-{ mkDerivation, base, fetchgit, stdenv }:
-mkDerivation {
- pname = "scanner";
- version = "1.0.0";
- src = fetchgit {
- url = http://cgit.cd.retiolum/scanner;
- rev = "7f091a3bc152ad3974a1873b460fa1759bf8dcad";
- sha256 = "7d123c227777932039d26fc832b8d32a90f04c0bd6b7e8bcff0a6f49a54e0054";
- };
- libraryHaskellDepends = [ base ];
- license = stdenv.lib.licenses.wtfpl;
-}
-) {};
- };
- };
-in
-
-hspkgs.callPackage (
+pkgs.haskellngPackages.callPackage (
{ mkDerivation, aeson, attoparsec, base, base64-bytestring
, blaze-builder, blessings, bytestring, case-insensitive, containers, deepseq
, directory, docopt, email-header, fetchgit, filepath