summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/kirk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/kirk.nix')
-rw-r--r--krebs/5pkgs/haskell/kirk.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/krebs/5pkgs/haskell/kirk.nix b/krebs/5pkgs/haskell/kirk.nix
index 073e5d50..d6fdec4c 100644
--- a/krebs/5pkgs/haskell/kirk.nix
+++ b/krebs/5pkgs/haskell/kirk.nix
@@ -1,5 +1,5 @@
-{ mkDerivation, async, base, bytestring, fetchgit, network
-, optparse-applicative, stdenv, text
+{ mkDerivation, async, base, bytestring, fetchgit, lib, network
+, optparse-applicative, text
}:
mkDerivation {
pname = "kirk";
@@ -8,6 +8,7 @@ mkDerivation {
url = "http://cgit.krebsco.de/kirk";
sha256 = "1acsmmc485c54axpy9bd0320j18hs261vl1vdxns4n04sxzqd7k0";
rev = "cdf3cb373af8f9b03a9487a63eb32e0226913589";
+ fetchSubmodules = true;
};
isLibrary = true;
isExecutable = true;
@@ -17,5 +18,5 @@ mkDerivation {
executableHaskellDepends = [
async base network optparse-applicative text
];
- license = stdenv.lib.licenses.mit;
+ license = lib.licenses.mit;
}