summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/brockman.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/brockman.nix')
-rw-r--r--krebs/5pkgs/haskell/brockman.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/brockman.nix b/krebs/5pkgs/haskell/brockman.nix
new file mode 100644
index 00000000..ed5dce03
--- /dev/null
+++ b/krebs/5pkgs/haskell/brockman.nix
@@ -0,0 +1,23 @@
+{ mkDerivation, aeson, async, base, bloomfilter, bytestring
+, conduit, containers, feed, hslogger, irc-conduit, microlens
+, network, optparse-applicative, stdenv, stm, text, wreq
+, fetchFromGitHub
+}:
+mkDerivation rec {
+ pname = "brockman";
+ version = "1.4.2";
+ src = fetchFromGitHub {
+ owner = "kmein";
+ repo = "brockman";
+ rev = version;
+ sha256 = "0y6ki8kj176knajjfnklrrwwqra23lpz10x5c603rgsjwxgwrxzk";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson async base bloomfilter bytestring conduit containers feed
+ hslogger irc-conduit microlens network optparse-applicative stm
+ text wreq
+ ];
+ license = stdenv.lib.licenses.mit;
+}