summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/default.nix')
-rw-r--r--krebs/5pkgs/default.nix77
1 files changed, 26 insertions, 51 deletions
diff --git a/krebs/5pkgs/default.nix b/krebs/5pkgs/default.nix
index 81481e14..39e89a4b 100644
--- a/krebs/5pkgs/default.nix
+++ b/krebs/5pkgs/default.nix
@@ -1,58 +1,33 @@
-pkgs: oldpkgs:
with import <stockholm/lib>;
- let
- # This callPackage will try to detect obsolete overrides.
- callPackage = path: args: let
- override = pkgs.callPackage path args;
- upstream = optionalAttrs (override ? "name")
- (oldpkgs.${(parseDrvName override.name).name} or {});
- in if upstream ? "name" &&
- override ? "name" &&
- compareVersions upstream.name override.name != -1
- then trace "Upstream `${upstream.name}' gets overridden by `${override.name}'." override
- else override;
- in {}
- // import ./writers.nix pkgs oldpkgs
- // mapAttrs (_: flip callPackage {})
- (filterAttrs (_: dir: pathExists (dir + "/default.nix"))
- (subdirsOf ./.))
- // {
- empty = pkgs.runCommand "empty-1.0.0" {} "mkdir $out";
- haskellPackages = oldpkgs.haskellPackages.override {
- overrides = self: super:
- mapAttrs (name: path: self.callPackage path {})
- (mapAttrs'
- (name: type:
- if hasSuffix ".nix" name
- then {
- name = removeSuffix ".nix" name;
- value = ./haskell-overrides + "/${name}";
- }
- else null)
- (builtins.readDir ./haskell-overrides));
- };
+self: super:
- ReaktorPlugins = callPackage ./Reaktor/plugins.nix {};
+# Import files and subdirectories like they are overlays.
+foldl' mergeAttrs {}
+ (map
+ (name: import (./. + "/${name}") self super)
+ (filter
+ (name: name != "default.nix" && !hasPrefix "." name)
+ (attrNames (readDir ./.))))
- buildbot = callPackage ./buildbot {};
- buildbot-full = callPackage ./buildbot {
- plugins = with pkgs.buildbot-plugins; [ www console-view waterfall-view ];
- };
- buildbot-worker = callPackage ./buildbot/worker.nix {};
+//
- # https://github.com/proot-me/PRoot/issues/106
- proot = pkgs.writeDashBin "proot" ''
- export PROOT_NO_SECCOMP=1
- exec ${oldpkgs.proot}/bin/proot "$@"
- '';
+{
+ ReaktorPlugins = self.callPackage ./simple/Reaktor/plugins.nix {};
- # XXX symlinkJoin changed arguments somewhere around nixpkgs d541e0d
- symlinkJoin = { name, paths, ... }@args: let
- x = oldpkgs.symlinkJoin args;
- in if typeOf x != "lambda" then x else oldpkgs.symlinkJoin name paths;
+ buildbot-full = self.callPackage ./simple/buildbot {
+ plugins = with self.buildbot-plugins; [ www console-view waterfall-view ];
+ };
+ buildbot-worker = self.callPackage ./simple/buildbot/worker.nix {};
- test = {
- infest-cac-centos7 = callPackage ./test/infest-cac-centos7 {};
- };
- }
+ # https://github.com/proot-me/PRoot/issues/106
+ proot = self.writeDashBin "proot" ''
+ export PROOT_NO_SECCOMP=1
+ exec ${super.proot}/bin/proot "$@"
+ '';
+
+ # XXX symlinkJoin changed arguments somewhere around nixpkgs d541e0d
+ symlinkJoin = { name, paths, ... }@args: let
+ x = super.symlinkJoin args;
+ in if typeOf x != "lambda" then x else super.symlinkJoin name paths;
+}