summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 42262729..7792b31d 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -147,8 +147,14 @@ types // rec {
options = {
path = mkOption { type = str; };
mode = mkOption { type = str; default = "0400"; };
- owner-name = mkOption { type = str; default = "root"; };
- group-name = mkOption { type = str; default = "root"; };
+ owner = mkOption {
+ type = user;
+ default = config.krebs.users.root;
+ };
+ group-name = mkOption {
+ type = str;
+ default = "root";
+ };
source-path = mkOption {
type = str;
default = toString <secrets> + "/${config._module.args.name}";