summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 41af1cd4..42262729 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -179,6 +179,10 @@ types // rec {
pubkey = mkOption {
type = str;
};
+ uid = mkOption {
+ type = int;
+ default = genid config.name;
+ };
};
});