summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/shell.nix')
-rw-r--r--krebs/4lib/shell.nix22
1 files changed, 0 insertions, 22 deletions
diff --git a/krebs/4lib/shell.nix b/krebs/4lib/shell.nix
deleted file mode 100644
index 5910adac..00000000
--- a/krebs/4lib/shell.nix
+++ /dev/null
@@ -1,22 +0,0 @@
-{ lib, ... }:
-
-with builtins;
-with lib;
-
-rec {
- escape =
- let
- isSafeChar = c: match "[-+./0-9:=A-Z_a-z]" c != null;
- in
- stringAsChars (c:
- if isSafeChar c then c
- else if c == "\n" then "'\n'"
- else "\\${c}");
-
- #
- # shell script generators
- #
-
- # example: "${cat (toJSON { foo = "bar"; })} | jq -r .foo"
- cat = s: "printf '%s' ${escape s}";
-}