summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/git.nix')
-rw-r--r--krebs/4lib/git.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/krebs/4lib/git.nix b/krebs/4lib/git.nix
deleted file mode 100644
index 005c017a..00000000
--- a/krebs/4lib/git.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ lib, ... }:
-
-with lib;
-
-let
- addName = name: set:
- set // { inherit name; };
-
- addNames = mapAttrs addName;
-
- commands = addNames {
- git-receive-pack = {};
- git-upload-pack = {};
- };
-
- receive-modes = addNames {
- fast-forward = {};
- non-fast-forward = {};
- create = {};
- delete = {};
- merge = {}; # TODO implement in git.nix
- };
-
- permissions = {
- fetch = {
- allow-commands = [
- commands.git-upload-pack
- ];
- };
-
- push = ref: extra-modes: {
- allow-commands = [
- commands.git-receive-pack
- commands.git-upload-pack
- ];
- allow-receive-ref = ref;
- allow-receive-modes = [ receive-modes.fast-forward ] ++ extra-modes;
- };
- };
-
- refs = {
- master = "refs/heads/master";
- all-heads = "refs/heads/*";
- };
-
-in
-commands // receive-modes // permissions // refs