summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/users.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/users.nix')
-rw-r--r--krebs/3modules/users.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/krebs/3modules/users.nix b/krebs/3modules/users.nix
index c1ad4b44..614e6ab4 100644
--- a/krebs/3modules/users.nix
+++ b/krebs/3modules/users.nix
@@ -1,8 +1,8 @@
-{ config, ... }: let
- lib = import ../../lib;
+{ config, lib, pkgs, ... }: let
+ slib = import ../../lib/pure.nix { inherit lib; };
in {
options.krebs.users = lib.mkOption {
- type = with lib.types; attrsOf user;
+ type = lib.types.attrsOf slib.types.user;
};
config = lib.mkIf config.krebs.enable {
krebs.users = {