summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/urlwatch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/urlwatch.nix')
-rw-r--r--krebs/3modules/urlwatch.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/krebs/3modules/urlwatch.nix b/krebs/3modules/urlwatch.nix
index 3c9ff770..61ee72e7 100644
--- a/krebs/3modules/urlwatch.nix
+++ b/krebs/3modules/urlwatch.nix
@@ -16,9 +16,6 @@ let
api = {
enable = mkEnableOption "krebs.urlwatch";
-
- customSendmail.enable = mkEnableOption "krebs.urlwatch.customSendmail";
-
dataDir = mkOption {
type = types.str;
default = "/var/lib/urlwatch";
@@ -56,8 +53,11 @@ let
The format is described in systemd.time(7), CALENDAR EVENTS.
'';
};
+ sendmail.enable = mkEnableOption "krebs.urlwatch.sendmail" // {
+ default = true;
+ };
telegram = {
- enable = mkEnableOption "krebs.urlwatch.telegram" // { default = false; };
+ enable = mkEnableOption "krebs.urlwatch.telegram";
botToken = mkOption {
type = types.str;
};
@@ -174,7 +174,7 @@ let
--urls=${shell.escape urlsFile} \
> changes || :
- ${optionalString cfg.customSendmail.enable /* sh */ ''
+ ${optionalString cfg.sendmail.enable /* sh */ ''
if test -s changes; then
{
echo Date: $(date -R)