summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/solanum.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/solanum.nix')
-rw-r--r--krebs/3modules/solanum.nix107
1 files changed, 107 insertions, 0 deletions
diff --git a/krebs/3modules/solanum.nix b/krebs/3modules/solanum.nix
new file mode 100644
index 00000000..1d084dd4
--- /dev/null
+++ b/krebs/3modules/solanum.nix
@@ -0,0 +1,107 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (lib) mkEnableOption mkIf mkOption singleton types;
+ inherit (pkgs) coreutils solanum;
+ cfg = config.krebs.solanum;
+
+ configFile = pkgs.writeText "solanum.conf" ''
+ ${cfg.config}
+ '';
+in
+
+{
+
+ ###### interface
+
+ options = {
+
+ krebs.solanum = {
+
+ enable = mkEnableOption "Solanum IRC daemon";
+
+ config = mkOption {
+ type = types.str;
+ description = ''
+ Solanum IRC daemon configuration file.
+ '';
+ };
+
+ statedir = mkOption {
+ type = types.path;
+ default = "/var/lib/solanum";
+ description = ''
+ Location of the state directory of solanum.
+ '';
+ };
+
+ user = mkOption {
+ type = types.str;
+ default = "ircd";
+ description = ''
+ Solanum IRC daemon user.
+ '';
+ };
+
+ group = mkOption {
+ type = types.str;
+ default = "ircd";
+ description = ''
+ Solanum IRC daemon group.
+ '';
+ };
+
+ motd = mkOption {
+ type = types.nullOr types.lines;
+ default = null;
+ description = ''
+ Solanum MOTD text.
+
+ Solanum will read its MOTD from /etc/solanum/ircd.motd .
+ If set, the value of this option will be written to this path.
+ '';
+ };
+
+ };
+
+ };
+
+
+ ###### implementation
+
+ config = mkIf cfg.enable (lib.mkMerge [
+ {
+ users.users.${cfg.user} = {
+ description = "Solanum IRC daemon user";
+ uid = config.ids.uids.ircd;
+ group = cfg.group;
+ };
+
+ users.groups.${cfg.group} = {
+ gid = config.ids.gids.ircd;
+ };
+
+ systemd.tmpfiles.rules = [
+ "d ${cfg.statedir} - ${cfg.user} ${cfg.group} - -"
+ ];
+
+ systemd.services.solanum = {
+ description = "Solanum IRC daemon";
+ wantedBy = [ "multi-user.target" ];
+ environment = {
+ BANDB_DBPATH = "${cfg.statedir}/ban.db";
+ };
+ serviceConfig = {
+ ExecStart = "${solanum}/bin/solanum -foreground -logfile /dev/stdout -configfile ${configFile}";
+ Group = cfg.group;
+ User = cfg.user;
+ };
+ };
+
+ }
+
+ (mkIf (cfg.motd != null) {
+ environment.etc."solanum/ircd.motd".text = cfg.motd;
+ })
+ ]);
+}