summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/shadow.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/shadow.nix')
-rw-r--r--krebs/3modules/shadow.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/krebs/3modules/shadow.nix b/krebs/3modules/shadow.nix
index f056cfd8..281b446b 100644
--- a/krebs/3modules/shadow.nix
+++ b/krebs/3modules/shadow.nix
@@ -1,5 +1,6 @@
-with import <stockholm/lib>;
-{ config, pkgs, ... }: let
+{ config, pkgs, lib, ... }:
+with lib;
+let
cfg = config.krebs.shadow;
@@ -47,7 +48,7 @@ in {
default = cfg.overridesFile != null;
};
overridesFile = mkOption {
- apply = x: if typeOf x == "path" then toString x else x;
+ apply = x: if builtins.typeOf x == "path" then toString x else x;
default = null;
description = ''
Path to a file containing additional shadow entries, used for adding