summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/iana-etc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/iana-etc.nix')
-rw-r--r--krebs/3modules/iana-etc.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/krebs/3modules/iana-etc.nix b/krebs/3modules/iana-etc.nix
index 9ed5f29c..dabe2f8a 100644
--- a/krebs/3modules/iana-etc.nix
+++ b/krebs/3modules/iana-etc.nix
@@ -1,5 +1,6 @@
-with import <stockholm/lib>;
-{ config, pkgs, ... }: {
+{ config, lib, pkgs, ... }: let
+ slib = import ../../lib/pure.nix { inherit lib; };
+in with lib; {
options.krebs.iana-etc.services = mkOption {
default = {};
@@ -7,7 +8,7 @@ with import <stockholm/lib>;
options = {
port = mkOption {
default = config._module.args.name;
- type = types.addCheck types.str (test "[1-9][0-9]*");
+ type = types.addCheck types.str (slib.test "[1-9][0-9]*");
};
} // genAttrs ["tcp" "udp"] (protocol: mkOption {
default = null;
@@ -30,7 +31,7 @@ with import <stockholm/lib>;
(proto: let
line = "${entry.${proto}.name} ${entry.port}/${proto}";
in /* sh */ ''
- echo ${shell.escape line}
+ echo ${slib.shell.escape line}
'')
(filter (proto: entry.${proto} != null) ["tcp" "udp"])}
'') (attrValues config.krebs.iana-etc.services)}