summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/git.nix')
-rw-r--r--krebs/3modules/git.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/krebs/3modules/git.nix b/krebs/3modules/git.nix
index 884108eb..93211d9d 100644
--- a/krebs/3modules/git.nix
+++ b/krebs/3modules/git.nix
@@ -569,7 +569,8 @@ let
if ! test -d "$repodir"; then
mkdir -m "$mode" "$repodir"
git init --bare --template=/var/empty "$repodir"
- chown -R git:nogroup "$repodir"
+ # TODO fix correctly with stringAfter
+ chown -R ${toString config.users.users.git.uid}:nogroup "$repodir"
fi
ln -s ${hooks} "$repodir/hooks"
''