summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/current.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/current.nix')
-rw-r--r--krebs/3modules/current.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/krebs/3modules/current.nix b/krebs/3modules/current.nix
new file mode 100644
index 00000000..41941e28
--- /dev/null
+++ b/krebs/3modules/current.nix
@@ -0,0 +1,26 @@
+{ config, pkgs, lib, ... }:
+
+with lib;
+
+let
+ cfg = config.krebs.current;
+
+ out = {
+ options.krebs.current = api;
+ config = mkIf cfg.enable imp;
+ };
+
+ api = {
+ enable = mkEnableOption "krebs.current";
+ host = mkOption {
+ type = types.host;
+ };
+ user = mkOption {
+ type = types.user;
+ };
+ };
+
+ imp = {
+ };
+
+in out