summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/current.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-25 14:15:21 +0100
committertv <tv@shackspace.de>2015-10-25 14:15:21 +0100
commit8f15daf2ea25304e9cbc8d449fb92078b2fb6f03 (patch)
tree7291d63e67340d31b3be8677fe2f8c56e8f3b653 /krebs/3modules/current.nix
parentdaa8fe2aa83451e7d4fc120f7fd417409ac2666c (diff)
init krebs.current
Diffstat (limited to 'krebs/3modules/current.nix')
-rw-r--r--krebs/3modules/current.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/krebs/3modules/current.nix b/krebs/3modules/current.nix
new file mode 100644
index 00000000..41941e28
--- /dev/null
+++ b/krebs/3modules/current.nix
@@ -0,0 +1,26 @@
+{ config, pkgs, lib, ... }:
+
+with lib;
+
+let
+ cfg = config.krebs.current;
+
+ out = {
+ options.krebs.current = api;
+ config = mkIf cfg.enable imp;
+ };
+
+ api = {
+ enable = mkEnableOption "krebs.current";
+ host = mkOption {
+ type = types.host;
+ };
+ user = mkOption {
+ type = types.user;
+ };
+ };
+
+ imp = {
+ };
+
+in out