summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/airdcpp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/airdcpp.nix')
-rw-r--r--krebs/3modules/airdcpp.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/krebs/3modules/airdcpp.nix b/krebs/3modules/airdcpp.nix
index 8c72680f..1633840f 100644
--- a/krebs/3modules/airdcpp.nix
+++ b/krebs/3modules/airdcpp.nix
@@ -84,6 +84,7 @@ let
default = null;
};
dcpp = {
+ # entries in DCPlusPlus.xml
Nick = mkOption {
description = ''
Nick Name for connection
@@ -116,6 +117,11 @@ let
type = str;
default = "100";
};
+ DownloadDirectory = mkOption {
+ description = "Directory, where new files will be saved into";
+ type = str;
+ default = "${cfg.stateDir}/Download";
+ };
shares = mkOption {
default = {};
type = attrsOf (submodule ( { config, ... }: {
@@ -218,6 +224,7 @@ let
<InPort type="int">${toString cfg.dcpp.InPort}</InPort>
<UDPPort type="int">${toString cfg.dcpp.UDPPort}</UDPPort>
<TLSPort type="int">${toString cfg.dcpp.TLSPort}</TLSPort>
+ <DownloadDirectory type="string">${cfg.dcpp.DownloadDirectory}</DownloadDirectory>
<AutoDetectIncomingConnection type="int">0</AutoDetectIncomingConnection>
<NoIpOverride type="int">1</NoIpOverride>
<WizardRunNew type="int">0</WizardRunNew>