summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/syncthing.nix')
-rw-r--r--krebs/2configs/syncthing.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/krebs/2configs/syncthing.nix b/krebs/2configs/syncthing.nix
index d6d42ca1..e5a785f0 100644
--- a/krebs/2configs/syncthing.nix
+++ b/krebs/2configs/syncthing.nix
@@ -1,4 +1,6 @@
-{ options, config, pkgs, ... }: with import <stockholm/lib>; let
+{ options, config, lib, pkgs, ... }:
+with import ../../lib/lib.nix { inherit lib; };
+let
mk_peers = mapAttrs (n: v: { id = v.syncthing.id; });
all_peers = filterAttrs (n: v: v.syncthing.id != null) config.krebs.hosts;