summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/nix-cacher.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/nix-cacher.nix')
-rw-r--r--krebs/2configs/shack/nix-cacher.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/krebs/2configs/shack/nix-cacher.nix b/krebs/2configs/shack/nix-cacher.nix
new file mode 100644
index 00000000..8feeca9a
--- /dev/null
+++ b/krebs/2configs/shack/nix-cacher.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+with import <stockholm/lib>;
+let
+ cfg = config.krebs.apt-cacher-ng;
+in
+{
+ imports = [
+ ./bincache.nix
+ ];
+ krebs.apt-cacher-ng = {
+ enable = true;
+ port = 3142;
+ bindAddress = "localhost";
+ cacheExpiration = 30;
+ };
+
+ services.nginx = {
+ enable = mkDefault true;
+ virtualHosts.shack-nix-cacher = {
+ serverAliases = [
+ "acng.shack"
+ ];
+ locations."/".extraConfig = ''
+ proxy_set_header Host $host;
+ proxy_set_header X-Real-IP $remote_addr;
+ proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+ proxy_pass http://localhost:${toString cfg.port}/;
+ '';
+ };
+ };
+}