summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/mqtt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/mqtt.nix')
-rw-r--r--krebs/2configs/shack/mqtt.nix22
1 files changed, 14 insertions, 8 deletions
diff --git a/krebs/2configs/shack/mqtt.nix b/krebs/2configs/shack/mqtt.nix
index e78f0f97..8ace4238 100644
--- a/krebs/2configs/shack/mqtt.nix
+++ b/krebs/2configs/shack/mqtt.nix
@@ -1,15 +1,21 @@
-# hostname: mqtt.shack
+{ ... }:
{
networking.firewall.allowedTCPPorts = [ 1883 ];
networking.firewall.allowedUDPPorts = [ 1883 ];
services.mosquitto = {
enable = true;
- host = "0.0.0.0";
- users = {};
- # TODO: secure that shit
- aclExtraConf = ''
- pattern readwrite #
- '';
- allowAnonymous = true;
+ persistence = false;
+ settings.max_keepalive = 60;
+ listeners = [
+ {
+ port = 1883;
+ omitPasswordAuth = true;
+ users = {};
+ settings = {
+ allow_anonymous = true;
+ };
+ acl = [ "topic readwrite #" "pattern readwrite #" ];
+ }
+ ];
};
}