summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/shack/glados/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/shack/glados/default.nix')
-rw-r--r--krebs/2configs/shack/glados/default.nix19
1 files changed, 12 insertions, 7 deletions
diff --git a/krebs/2configs/shack/glados/default.nix b/krebs/2configs/shack/glados/default.nix
index d000af39..e48a5455 100644
--- a/krebs/2configs/shack/glados/default.nix
+++ b/krebs/2configs/shack/glados/default.nix
@@ -2,6 +2,7 @@
let
shackopen = import ./multi/shackopen.nix;
wasser = import ./multi/wasser.nix;
+ badair = import ./multi/schlechte_luft.nix;
in {
services.nginx.virtualHosts."hass.shack" = {
serverAliases = [ "glados.shack" ];
@@ -44,7 +45,7 @@ in {
autoExtraComponents = true;
config = {
homeassistant = {
- name = "Bureautomation";
+ name = "Glados";
time_zone = "Europe/Berlin";
latitude = "48.8265";
longitude = "9.0676";
@@ -89,7 +90,7 @@ in {
};
};
switch = wasser.switch;
- light = [];
+ light = badair.light;
media_player = [
{ platform = "mpd";
host = "lounge.mpd.shack";
@@ -99,7 +100,8 @@ in {
sensor =
(import ./sensors/hass.nix)
++ (import ./sensors/power.nix)
- ++ shackopen.sensor;
+ ++ shackopen.sensor
+ ++ badair.sensor;
binary_sensor = shackopen.binary_sensor;
@@ -113,8 +115,9 @@ in {
trusted_proxies = "127.0.0.1";
};
#conversation = {};
- #history = {};
- #logbook = {};
+ history = {};
+ logbook = {};
+ recorder = {};
tts = [
{ platform = "google_translate";
language = "de";
@@ -123,10 +126,12 @@ in {
# language = "de-DE";
#}
];
- #recorder = {};
sun = {};
- automation = wasser.automation;
+ automation = wasser.automation
+ ++ badair.automation
+ ++ (import ./automation/hass-restart.nix);
+
device_tracker = [];
};
};