summaryrefslogtreecommitdiffstats
path: root/krebs/1systems/ponte/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/1systems/ponte/hw.nix')
-rw-r--r--krebs/1systems/ponte/hw.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/krebs/1systems/ponte/hw.nix b/krebs/1systems/ponte/hw.nix
new file mode 100644
index 00000000..83b53748
--- /dev/null
+++ b/krebs/1systems/ponte/hw.nix
@@ -0,0 +1,13 @@
+{ modulesPath, ... }:
+{
+ imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
+ boot.loader.grub = {
+ efiSupport = true;
+ efiInstallAsRemovable = true;
+ device = "nodev";
+ copyKernels = false;
+ };
+ fileSystems."/boot" = { device = "/dev/disk/by-uuid/628A-7F3B"; fsType = "vfat"; };
+ boot.initrd.kernelModules = [ "nvme" ];
+ fileSystems."/" = { device = "/dev/sda1"; fsType = "ext4"; };
+}