summaryrefslogtreecommitdiffstats
path: root/kartei/srounce/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'kartei/srounce/default.nix')
-rw-r--r--kartei/srounce/default.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/kartei/srounce/default.nix b/kartei/srounce/default.nix
index ef37cbcd..e0c1be96 100644
--- a/kartei/srounce/default.nix
+++ b/kartei/srounce/default.nix
@@ -1,13 +1,12 @@
-{ config, ... }: let
- lib = import ../../lib;
-
+{ config, lib, ... }: let
+ slib = import ../../lib/pure.nix { inherit lib; };
hostDefaults = hostName: host: lib.flip lib.recursiveUpdate host ({
ci = false;
external = true;
monitoring = false;
} // lib.optionalAttrs (host.nets?retiolum) {
nets.retiolum.ip6.addr =
- (lib.krebs.genipv6 "retiolum" "external" { inherit hostName; }).address;
+ (slib.krebs.genipv6 "retiolum" "external" { inherit hostName; }).address;
});
in {