summaryrefslogtreecommitdiffstats
path: root/jeschli/source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/source.nix')
-rw-r--r--jeschli/source.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/jeschli/source.nix b/jeschli/source.nix
new file mode 100644
index 00000000..d5e14a8d
--- /dev/null
+++ b/jeschli/source.nix
@@ -0,0 +1,22 @@
+with import <stockholm/lib>;
+host@{ name, secure ? false, override ? {} }: let
+ builder = if getEnv "dummy_secrets" == "true"
+ then "buildbot"
+ else "jeschli";
+ _file = <stockholm> + "/jeschli/1systems/${name}/source.nix";
+in
+ evalSource (toString _file) [
+ {
+ nixos-config.symlink = "stockholm/jeschli/1systems/${name}/config.nix";
+ nixpkgs.git = {
+ url = https://github.com/nixos/nixpkgs;
+ ref = "f9390d6";
+ };
+ secrets.file = getAttr builder {
+ buildbot = toString <stockholm/jeschli/2configs/tests/dummy-secrets>;
+ jeschli = "/home/jeschli/secrets/${name}";
+ };
+ stockholm.file = toString <stockholm>;
+ }
+ override
+ ]