summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/reagenzglas/i3-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/1systems/reagenzglas/i3-configuration.nix')
-rw-r--r--jeschli/1systems/reagenzglas/i3-configuration.nix181
1 files changed, 0 insertions, 181 deletions
diff --git a/jeschli/1systems/reagenzglas/i3-configuration.nix b/jeschli/1systems/reagenzglas/i3-configuration.nix
deleted file mode 100644
index 88f63426..00000000
--- a/jeschli/1systems/reagenzglas/i3-configuration.nix
+++ /dev/null
@@ -1,181 +0,0 @@
-{pkgs, environment, config, lib, ... }:
-
-with pkgs;
-
-let
- i3_config_file = pkgs.writeText "config" ''
- set $mod Mod4
-
- font pango:monospace 8
-
- #font pango:DejaVu Sans Mono 8
-
- # Before i3 v4.8, we used to recommend this one as the default:
- # font -misc-fixed-medium-r-normal--13-120-75-75-C-70-iso10646-1
- # The font above is very space-efficient, that is, it looks good, sharp and
- # clear in small sizes. However, its unicode glyph coverage is limited, the old
- # X core fonts rendering does not support right-to-left and this being a bitmap
- # font, it doesn’t scale on retina/hidpi displays.
-
- # Use Mouse+$mod to drag floating windows to their wanted position
- floating_modifier $mod
-
- # start a terminal
- bindsym $mod+Return exec alacritty
-
- # kill focused window
- bindsym $mod+Shift+q kill
-
- # start dmenu (a program launcher)
- # bindsym $mod+d exec dmenu_run
-
- # start dmenu (a program launcher)
- bindsym $mod+d exec ${pkgs.rofi}/bin/rofi -modi drun#run -combi-modi drun#run -show combi -show-icons -display-combi run
-
- bindsym $mod+x exec ${pkgs.rofi}/bin/rofi -modi window -show window -auto-select
-
- bindsym $mod+F1 exec xinput --list | grep Touchpad | sed 's/.*id=\([0-9][0-9]\).*/\1/' | xargs xinput disable
- bindsym $mod+F2 exec xinput --list | grep Touchpad | sed 's/.*id=\([0-9][0-9]\).*/\1/' | xargs xinput enable
-
- # There also is the (new) i3-dmenu-desktop which only displays applications
- # shipping a .desktop file. It is a wrapper around dmenu, so you need that
- # installed.
- # bindsym $mod+d exec --no-startup-id i3-dmenu-desktop
-
- # change focus
- bindsym $mod+j focus left
- bindsym $mod+k focus down
- bindsym $mod+l focus up
- bindsym $mod+semicolon focus right
-
- # alternatively, you can use the cursor keys:
- bindsym $mod+Left focus left
- bindsym $mod+Down focus down
- bindsym $mod+Up focus up
- bindsym $mod+Right focus right
-
- # move focused window
- bindsym $mod+Shift+j move left
- bindsym $mod+Shift+k move down
- bindsym $mod+Shift+l move up
- bindsym $mod+Shift+colon move right
-
- # alternatively, you can use the cursor keys:
- bindsym $mod+Shift+Left move left
- bindsym $mod+Shift+Down move down
- bindsym $mod+Shift+Up move up
- bindsym $mod+Shift+Right move right
-
- # split in horizontal orientation
- bindsym $mod+h split h
-
- # split in vertical orientation
- bindsym $mod+v split v
-
- # enter fullscreen mode for the focused container
- bindsym $mod+f fullscreen toggle
-
- # change container layout (stacked, tabbed, toggle split)
- bindsym $mod+s layout stacking
- bindsym $mod+w layout tabbed
- bindsym $mod+e layout toggle split
-
- # toggle tiling / floating
- bindsym $mod+Shift+space floating toggle
-
- # change focus between tiling / floating windows
- bindsym $mod+space focus mode_toggle
-
- # focus the parent container
- bindsym $mod+a focus parent
-
- # focus the child container
- #bindsym $mod+d focus child
-
- # Define names for default workspaces for which we configure key bindings later on.
- # We use variables to avoid repeating the names in multiple places.
- set $ws1 "1"
- set $ws2 "2"
- set $ws3 "3"
- set $ws4 "4"
- set $ws5 "5"
- set $ws6 "6"
- set $ws7 "7"
- set $ws8 "8"
- set $ws9 "9"
- set $ws10 "10"
-
- # switch to workspace
- bindsym $mod+1 workspace $ws1
- bindsym $mod+2 workspace $ws2
- bindsym $mod+3 workspace $ws3
- bindsym $mod+4 workspace $ws4
- bindsym $mod+5 workspace $ws5
- bindsym $mod+6 workspace $ws6
- bindsym $mod+7 workspace $ws7
- bindsym $mod+8 workspace $ws8
- bindsym $mod+9 workspace $ws9
- bindsym $mod+0 workspace $ws10
-
- # move focused container to workspace
- bindsym $mod+Shift+1 move container to workspace $ws1
- bindsym $mod+Shift+2 move container to workspace $ws2
- bindsym $mod+Shift+3 move container to workspace $ws3
- bindsym $mod+Shift+4 move container to workspace $ws4
- bindsym $mod+Shift+5 move container to workspace $ws5
- bindsym $mod+Shift+6 move container to workspace $ws6
- bindsym $mod+Shift+7 move container to workspace $ws7
- bindsym $mod+Shift+8 move container to workspace $ws8
- bindsym $mod+Shift+9 move container to workspace $ws9
- bindsym $mod+Shift+0 move container to workspace $ws10
-
- # reload the configuration file
- bindsym $mod+Shift+c reload
- # restart i3 inplace (preserves your layout/session, can be used to upgrade i3)
- bindsym $mod+Shift+r restart
- # exit i3 (logs you out of your X session)
- bindsym $mod+Shift+e exec "i3-nagbar -t warning -m 'You pressed the exit shortcut. Do you really want to exit i3? This will end your X session.' -B 'Yes, exit i3' 'i3-msg exit'"
-
- # resize window (you can also use the mouse for that)
- mode "resize" {
- # These bindings trigger as soon as you enter the resize mode
-
- # Pressing left will shrink the window’s width.
- # Pressing right will grow the window’s width.
- # Pressing up will shrink the window’s height.
- # Pressing down will grow the window’s height.
- bindsym j resize shrink width 10 px or 10 ppt
- bindsym k resize grow height 10 px or 10 ppt
- bindsym l resize shrink height 10 px or 10 ppt
- bindsym semicolon resize grow width 10 px or 10 ppt
-
- # same bindings, but for the arrow keys
- bindsym Left resize shrink width 10 px or 10 ppt
- bindsym Down resize grow height 10 px or 10 ppt
- bindsym Up resize shrink height 10 px or 10 ppt
- bindsym Right resize grow width 10 px or 10 ppt
-
- # back to normal: Enter or Escape or $mod+r
- bindsym Return mode "default"
- bindsym Escape mode "default"
- bindsym $mod+r mode "default"
- }
-
- bindsym $mod+r mode "resize"
-
- # Start i3bar to display a workspace bar (plus the system information i3status
- # finds out, if available)
- bar {
- status_command i3status
- }
- '';
-
-in {
-
- services.xserver.windowManager.i3 = {
- enable = true;
- package = pkgs.i3;
- configFile = i3_config_file;
- };
-
-}