summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index b561cb7d..7223a46e 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,10 @@
-{ current-date
-, current-host-name
-, current-user-name
+{ current-date ? abort "current-date not defined"
+, current-host-name ? abort "current-host-name not defined"
+, current-user-name ? builtins.getEnv "LOGNAME"
}:
+assert current-user-name != "";
+
let
lib = import <nixpkgs/lib>;