summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-17 06:30:20 +0200
committertv <tv@shackspace.de>2015-10-17 06:30:20 +0200
commit41dc859d7ed956addd01579a114549c1984206c5 (patch)
tree2509b6169dbbbe5f4cb36f1e2103244391c2ba89 /default.nix
parentfbab9828dac3df55db4b665d5b79983477ec2717 (diff)
allow nix-env -f <stockholm>
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index b561cb7d..7223a46e 100644
--- a/default.nix
+++ b/default.nix
@@ -1,8 +1,10 @@
-{ current-date
-, current-host-name
-, current-user-name
+{ current-date ? abort "current-date not defined"
+, current-host-name ? abort "current-host-name not defined"
+, current-user-name ? builtins.getEnv "LOGNAME"
}:
+assert current-user-name != "";
+
let
lib = import <nixpkgs/lib>;