summaryrefslogtreecommitdiffstats
path: root/2configs/tv/consul-server.nix
diff options
context:
space:
mode:
Diffstat (limited to '2configs/tv/consul-server.nix')
-rw-r--r--2configs/tv/consul-server.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/2configs/tv/consul-server.nix b/2configs/tv/consul-server.nix
new file mode 100644
index 00000000..1c8dcb88
--- /dev/null
+++ b/2configs/tv/consul-server.nix
@@ -0,0 +1,22 @@
+{ config, ... }:
+
+{
+ imports = [ ../../3modules/tv/consul.nix ];
+ tv.consul = rec {
+ enable = true;
+
+ inherit (config.tv.identity) self;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.tv.identity.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}