summaryrefslogtreecommitdiffstats
path: root/tv/source.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-06 21:47:47 +0200
committertv <tv@krebsco.de>2017-07-10 11:05:48 +0200
commit7fdc46bb9d911838edfa723d985ede6a604c0c5a (patch)
tree3ceb366c12f0bc229cfcd5fce6c2f409e29fe06b /tv/source.nix
parentfc3f5d3d56a299b7b46c1a42d3fec57c536a5917 (diff)
move source config from module system to 1systems/*/source.nix
Diffstat (limited to 'tv/source.nix')
-rw-r--r--tv/source.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tv/source.nix b/tv/source.nix
new file mode 100644
index 00000000..7306cd95
--- /dev/null
+++ b/tv/source.nix
@@ -0,0 +1,22 @@
+with import <stockholm/lib>;
+host@{ name, secure ? false }: let
+ builder = if getEnv "dummy_secrets" == "true"
+ then "buildbot"
+ else "tv";
+ _file = <stockholm> + "/tv/1systems/${name}/source.nix";
+in
+ evalSource (toString _file) {
+ nixos-config.symlink = "stockholm/tv/1systems/${name}/config.nix";
+ secrets.file = getAttr builder {
+ buildbot = toString <stockholm/tv/dummy_secrets>;
+ tv = "/home/tv/secrets/${name}";
+ };
+ stockholm.file = toString <stockholm>;
+ secrets-common.file = "/home/tv/secrets/common";
+ nixpkgs.git = {
+ url = https://github.com/NixOS/nixpkgs;
+ ref = "1b57bf274ae5c76e91b2b264d8aa8bfcecb72102"; # nixos-17.03
+ };
+ } // optionalAttrs secure {
+ secrets-master.file = "/home/tv/secrets/master";
+ }