summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple/viljetic-pages
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-07-23 02:46:44 +0200
committertv <tv@krebsco.de>2017-07-23 02:46:44 +0200
commit5762d122657217f964f4898d9f178ec2f843176a (patch)
tree45a2954577c7600ceff106865bd747369adc114c /tv/5pkgs/simple/viljetic-pages
parentdae4f8d5c072f645ad30100239383d1931d19a2b (diff)
tv pkgs: mimic krebs' simple overlay
Diffstat (limited to 'tv/5pkgs/simple/viljetic-pages')
-rw-r--r--tv/5pkgs/simple/viljetic-pages/default.nix16
-rw-r--r--tv/5pkgs/simple/viljetic-pages/index.html10
-rw-r--r--tv/5pkgs/simple/viljetic-pages/logo.xpm24
3 files changed, 50 insertions, 0 deletions
diff --git a/tv/5pkgs/simple/viljetic-pages/default.nix b/tv/5pkgs/simple/viljetic-pages/default.nix
new file mode 100644
index 00000000..1ae55cca
--- /dev/null
+++ b/tv/5pkgs/simple/viljetic-pages/default.nix
@@ -0,0 +1,16 @@
+{ pkgs, stdenv, ... }:
+
+stdenv.mkDerivation {
+ name = "viljetic-pages-0";
+ phases = [
+ "installPhase"
+ ];
+ buildInputs = with pkgs; [
+ imagemagick
+ ];
+ installPhase = ''
+ mkdir -p $out
+ cp ${./index.html} $out/index.html
+ convert ${./logo.xpm} $out/favicon2.png
+ '';
+}
diff --git a/tv/5pkgs/simple/viljetic-pages/index.html b/tv/5pkgs/simple/viljetic-pages/index.html
new file mode 100644
index 00000000..c06b3f97
--- /dev/null
+++ b/tv/5pkgs/simple/viljetic-pages/index.html
@@ -0,0 +1,10 @@
+<!DOCTYPE HTML>
+<title>blank page</title>
+<link rel="shortcut icon" href="favicon2.png" type="image/png">
+<i>This page intentionally left blank.</i>
+<!--
+ Ok, it's not blank, here are the cookies (bots welcome):
+ mailto:tomislav@viljetic.de
+ https://github.com/4z3
+ irc://freenode.net/#krebs
+-->
diff --git a/tv/5pkgs/simple/viljetic-pages/logo.xpm b/tv/5pkgs/simple/viljetic-pages/logo.xpm
new file mode 100644
index 00000000..bb263dad
--- /dev/null
+++ b/tv/5pkgs/simple/viljetic-pages/logo.xpm
@@ -0,0 +1,24 @@
+/* XPM */
+static char *meh[] = {
+/* columns rows colors chars-per-pixel */
+"16 16 2 1 ",
+" c black",
+". c None",
+/* pixels */
+"................",
+". ...... .",
+". .. ...... .. .",
+". .. ...... .. .",
+". ...... .",
+"................",
+". . . .",
+". .. . .. . .",
+". .. . .. . .",
+". . . .",
+"................",
+"...... . .",
+"...... . .",
+"...... . .",
+"...... . .",
+"................"
+};