summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple/fzmenu/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-06-06 19:15:44 +0200
committermakefu <github@syntax-fehler.de>2021-06-06 19:15:44 +0200
commit74058abe0b5da0753c2167d6bab29eb1eae88366 (patch)
tree748e9e75c0498161629597f7469933e69303168b /tv/5pkgs/simple/fzmenu/default.nix
parent88a845f7a1a037bf6bcf23863d41f36c4cedcd7e (diff)
parenta5bc9126db72f59062ff9d6a72b2fa35437b42cb (diff)
Merge branch '21.05'
Diffstat (limited to 'tv/5pkgs/simple/fzmenu/default.nix')
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
index 35918ff7..1f1b8284 100644
--- a/tv/5pkgs/simple/fzmenu/default.nix
+++ b/tv/5pkgs/simple/fzmenu/default.nix
@@ -1,4 +1,7 @@
-{ coreutils, dash, gnused, fzf, pass-otp, runCommand, rxvt_unicode, stdenv, utillinux, xdotool }:
+{ lib, stdenv
+, runCommand
+, coreutils, dash, gnused, fzf, pass-otp, rxvt_unicode, utillinux, xdotool
+}:
runCommand "fzmenu" {
} /* sh */ ''
@@ -8,7 +11,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/otpmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf
@@ -21,7 +24,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/passmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf