summaryrefslogtreecommitdiffstats
path: root/tv/4lib/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-28 20:40:25 +0200
committertv <tv@shackspace.de>2015-07-28 20:40:25 +0200
commit8170b281964688b542fb151054c5d86d819008b3 (patch)
treea37b713c7662dbaef73508bca889c83c7dc5a620 /tv/4lib/default.nix
parenta7ff77b6c147be71d60bda7e73c65286ecfb7c83 (diff)
tv: reintroduce directory numbers
Diffstat (limited to 'tv/4lib/default.nix')
-rw-r--r--tv/4lib/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tv/4lib/default.nix b/tv/4lib/default.nix
new file mode 100644
index 00000000..dbc0c29b
--- /dev/null
+++ b/tv/4lib/default.nix
@@ -0,0 +1,22 @@
+{ lib, pkgs, ... }:
+
+with lib;
+
+lib // rec {
+
+ git = import ./git.nix {
+ inherit lib pkgs;
+ };
+
+ # "7.4.335" -> "74"
+ majmin = with lib; x : concatStrings (take 2 (splitString "." x));
+
+ shell-escape =
+ let
+ isSafeChar = c: match "[-./0-9_a-zA-Z]" c != null;
+ in
+ stringAsChars (c:
+ if isSafeChar c then c
+ else if c == "\n" then "'\n'"
+ else "\\${c}");
+}