summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xserver/xserver.conf.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-10-24 22:31:10 +0200
committertv <tv@shackspace.de>2015-10-24 22:31:10 +0200
commit0306ec4294f6d825ca65c7b0c98a80a3bced8fdf (patch)
treeeb9e3772407963c25a4d6bd8125b3a2a72bb29ca /tv/2configs/xserver/xserver.conf.nix
parentb2deab26bd52a994003cafc33872b6c084cdd716 (diff)
tv: lol display-manager
Diffstat (limited to 'tv/2configs/xserver/xserver.conf.nix')
-rw-r--r--tv/2configs/xserver/xserver.conf.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/tv/2configs/xserver/xserver.conf.nix b/tv/2configs/xserver/xserver.conf.nix
new file mode 100644
index 00000000..e8a997a9
--- /dev/null
+++ b/tv/2configs/xserver/xserver.conf.nix
@@ -0,0 +1,40 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+ cfg = config.services.xserver;
+in
+
+pkgs.stdenv.mkDerivation {
+ name = "xserver.conf";
+
+ xfs = optionalString (cfg.useXFS != false)
+ ''FontPath "${toString cfg.useXFS}"'';
+
+ inherit (cfg) config;
+
+ buildCommand =
+ ''
+ echo 'Section "Files"' >> $out
+ echo $xfs >> $out
+
+ for i in ${toString config.fonts.fonts}; do
+ if test "''${i:0:''${#NIX_STORE}}" == "$NIX_STORE"; then
+ for j in $(find $i -name fonts.dir); do
+ echo " FontPath \"$(dirname $j)\"" >> $out
+ done
+ fi
+ done
+
+ for i in $(find ${toString cfg.modules} -type d); do
+ if test $(echo $i/*.so* | wc -w) -ne 0; then
+ echo " ModulePath \"$i\"" >> $out
+ fi
+ done
+
+ echo 'EndSection' >> $out
+
+ echo "$config" >> $out
+ '';
+}