summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xserver/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2017-12-05 15:34:31 +0100
committertv <tv@krebsco.de>2017-12-05 15:34:31 +0100
commit60c436fec31511561e013592caa577cc5f3461da (patch)
tree1e5258efb018e7452596a039b4390aa031f86bac /tv/2configs/xserver/default.nix
parent8f785237b2dc46c63272e360cece351b2974cb6d (diff)
tv xserver: user -> cfg.user
Diffstat (limited to 'tv/2configs/xserver/default.nix')
-rw-r--r--tv/2configs/xserver/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/tv/2configs/xserver/default.nix b/tv/2configs/xserver/default.nix
index 8f3ee596..6688984e 100644
--- a/tv/2configs/xserver/default.nix
+++ b/tv/2configs/xserver/default.nix
@@ -1,7 +1,9 @@
{ config, pkgs, ... }@args:
with import <stockholm/lib>;
let
- user = config.krebs.build.user;
+ cfg = {
+ user = config.krebs.build.user;
+ };
in {
environment.systemPackages = [
@@ -25,7 +27,7 @@ in {
group = "wheel";
envp = {
DISPLAY = ":${toString config.services.xserver.display}";
- USER = user.name;
+ USER = cfg.user.name;
};
};
@@ -81,8 +83,8 @@ in {
SyslogIdentifier = "xmonad";
ExecStart = "${pkgs.xmonad-tv}/bin/xmonad";
ExecStop = "${pkgs.xmonad-tv}/bin/xmonad --shutdown";
- User = user.name;
- WorkingDirectory = user.home;
+ User = cfg.user.name;
+ WorkingDirectory = cfg.user.home;
};
};
@@ -125,7 +127,7 @@ in {
Restart = "always";
RestartSec = "2s";
StartLimitBurst = 0;
- User = user.name;
+ User = cfg.user.name;
};
};
}