summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xserver/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-11-28 14:41:56 +0100
committertv <tv@krebsco.de>2018-11-28 14:41:56 +0100
commit1d7fddc064fef5e77c48602e3524949893a92997 (patch)
tree9b791bed02f715463b925889ddb6720ef131e635 /tv/2configs/xserver/default.nix
parentd5551ed214479317925239a9801384c9c3aa9add (diff)
tv xmonad: add currentSystem to executable name
This prevents journal messges like: XMonad is recompiling and replacing itself another XMonad process because the current process is called "xmonad" but the compiled configuration should be called "xmonad-x86_64-linux"
Diffstat (limited to 'tv/2configs/xserver/default.nix')
-rw-r--r--tv/2configs/xserver/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tv/2configs/xserver/default.nix b/tv/2configs/xserver/default.nix
index d1345723..a44ece8b 100644
--- a/tv/2configs/xserver/default.nix
+++ b/tv/2configs/xserver/default.nix
@@ -100,8 +100,8 @@ in {
"\${XMONAD_CONFIG_DIR}"
"\${XMONAD_DATA_DIR}"
]}";
- ExecStart = "${pkgs.xmonad-tv}/bin/xmonad";
- ExecStop = "${pkgs.xmonad-tv}/bin/xmonad --shutdown";
+ ExecStart = "${pkgs.xmonad-tv}/bin/xmonad-${currentSystem}";
+ ExecStop = "${pkgs.xmonad-tv}/bin/xmonad-${currentSystem} --shutdown";
User = cfg.user.name;
WorkingDirectory = cfg.user.home;
};